Network issue at Poplarwood

Incident Report for NCSEAA DIT Status Page

Resolved

This incident has been resolved. Contact the IT Help Desk if you need further assistance.
Posted Jan 27, 2026 - 14:57 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 12:17 EST

Update

We are continuing to investigate this issue.
Posted Jan 27, 2026 - 12:01 EST

Investigating

We are actively investigating an issue with connecting to the network at the Poplarwood office
Posted Jan 27, 2026 - 12:00 EST
This incident affected: Internet Services (Wireless Network).