We have implemented a fix for the issue impacting remote access on the Primary VPN.
At this time, you can return to using your Primary VPN connection for normal access. Please do not use the Secondary VPN, while we work with our firewall vendor to recreate the issue and continue troubleshooting within the Secondary VPN environment.
Thank you. IT Help Desk
Posted May 20, 2026 - 15:33 EDT
Identified
We have identified the issue impacting remote users accessing internal resources and are currently working on a permanent resolution. In the meantime, if you experience connectivity or access issues, please use the Secondary VPN as a temporary workaround.
We will continue to provide updates as additional information becomes available.
Thank you. IT Help Desk
Posted May 20, 2026 - 13:07 EDT
Investigating
We are currently investigating an issue impacting remote users accessing internal resources, including Galahad, the Intranet, and shared network folders/files (such as the S:\ drive).
Our team is actively working to identify the cause and restore full access as quickly as possible. We will provide another update as soon as more information is available.
Thank you. IT Help Desk
Posted May 20, 2026 - 12:25 EDT
This incident affects: Core Services (Galahad Application, Intranet, File Server and shared folders).