Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 15, 2026 - 18:31 EDT
Scheduled
IT Operations will perform system maintenance activities tonight, Tuesday September 15th from 6:30PM - 8:30PM on the email server used for relaying email from several internal systems (iSeries, Content Navigator, SQL, FTS1, and a few others), to our Microsoft Office 365 environment. This maintenance event involves the installation of important vendor patches to the email server to resolve known vulnerabilities, bug fixes, and improve application and system performance. During this time, all email communications from internal systems to Office 365 will be queued for later delivery.
Employee email access will not be affected by this maintenance.
Contact the IT Help Desk by email at ithelp@ncseaa.edu or call 919-248-4631 if you have any questions about this scheduled maintenance event.
Thank you, IT Help Desk
Posted Sep 15, 2026 - 09:55 EDT
This scheduled maintenance affected: Core Services (Email Services).