Microsoft Office 365 Services
Incident Report for NCSEAA DIT Status Page
Resolved
This incident has been resolved.

If you have questions or experience any issues, please contact the IT Service Desk at extension 4631 or send an email to support@ncseaa.edu to open a support request for assistance.

Thank you,
The Department of Information Technology
Posted Sep 12, 2024 - 13:55 EDT
Monitoring
Microsoft implemented a fix and indicated that the issue no longer persists. DIT will continue to monitor the availability of Microsoft Office 365 applications.

If you have questions or experience any issues, please contact the IT Service Desk at extension 4631 or send an email to support@ncseaa.edu to open a support request for assistance.

Thank you,
The Department of Information Technology
Posted Sep 12, 2024 - 11:11 EDT
Investigating
Microsoft is investigating an issue where some users may be unable to access Microsoft Office 365 services. Additional updates will be provided as they are received.

If you have questions or experience any issues, please contact the IT Service Desk at extension 4631 or send an email to support@ncseaa.edu to open a support request for assistance.

Thank you,
The Department of Information Technology
Posted Sep 12, 2024 - 10:18 EDT
This incident affected: Office 365 Services (Microsoft Outlook, Microsoft Teams, Microsoft OneDrive, Microsoft Sharepoint, Office 365 Online).