Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 31, 2026 - 09:00 EST
Scheduled
DIT will perform system maintenance on Saturday, January 31, from 9:00 AM to 12:00 PM, during which both wired and wireless network access at the Poplarwood office will be unavailable.
There is no impact to remote users.
Contact the IT Help Desk by email ithelp@ncseaa.edu if you have any questions about this scheduled maintenance event.
Thank you, IT Help Desk
Posted Jan 29, 2026 - 15:43 EST
This scheduled maintenance affected: Internet Services (Wired Network, Wireless Network).