Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2026 - 07:00 EDT
Scheduled
Maintenance will take place on Friday, April 24, from 7:00 AM to 8:30 AM for the SEAA wireless network. During this time, the SEAA wireless network will be unavailable.
This maintenance window will be used to configure the wireless network to integrate with SEAA’s network access control (NAC) systems.
If you have any questions or experience issues after the maintenance, please contact the IT Help Desk.
Thank you, IT Help Desk
Posted Apr 21, 2026 - 11:50 EDT
This scheduled maintenance affected: Internet Services (Wireless Network).