Server Connectivity Issue

Incident Report for NCSEAA DIT Status Page

Resolved

This incident has been resolved.

Thank you.
IT Help Desk
Posted Sep 04, 2025 - 13:57 EDT

Monitoring

Microsoft completed repairs to the damaged fiber circuits at 11:23 a.m., restoring access to all impacted IT services. Please switch back to the primary VPN and email support@ncseaa.edu (or submit a ticket through https://help.ncseaa.edu/) if you need assistance.

We know these outages are a major disruption to your productivity. We will be reviewing the incident to see how we can be better prepared for similar events in the future. (If you are interested in being a part of this review, please let us know.)

We appreciate how well you adapted to the event and continued to move the Authority forward despite the technological challenges this morning.

Thank you.
IT Help Desk
Posted Sep 04, 2025 - 11:34 EDT

Update

Our ExpressRoute connection is still down, but Microsoft expects to complete repairs by noon today. Please continue to use the secondary VPN until services are restored.

What to do
• If you are working remotely, please use the Secondary VPN.
• If you are on-site, stop by the IT help desk kiosk for alternate connection options
• Email support@ncseaa.edu or submit a ticket through https://help.ncseaa.edu/ if you would like assistance

Next update
We will send another status update by 12:00 p.m. today.

Thank you.
IT Help Desk
Posted Sep 04, 2025 - 10:10 EDT

Identified

Microsoft’s internet circuit for the Government Cloud is down, impacting connectivity to several of our IT services. Please use the Secondary VPN until further notice.

What to do
• If you are on-site: We are exploring possible workarounds and will check in with on-site users individually.
• If you are remote: Please connect to the Secondary VPN. Most services should be operational through the secondary VPN, with the main exception being iSeries applications.

What is working normally
• Internet access
• MyPortal
• Microsoft 365, including email, Teams, OneDrive, etc.
• GoTo Phone system

What is not currently accessible
• Azure services, including intranet site, file shares (on the S:\ drive), SAS, Tableau, and misc. others
• Content Manager
• Galahad
• Poplarwood printers
• Misc. web portals, including Loan Lookup, CM Reference, and others

Our various IT systems are up and running, but we cannot easily access them without the ExpressRoute. Microsoft does not currently have an ETA for repair.

We will send another notification to let you know the status by 10:00 a.m. today.

Thank you.
IT Help Desk
Posted Sep 04, 2025 - 08:58 EDT

Update

We are continuing to investigate this issue.
Posted Sep 04, 2025 - 07:49 EDT

Investigating

We are currently investigating this issue.
Posted Sep 04, 2025 - 07:45 EDT
This incident affected: Core Services (Content Manager, Galahad Application, Intranet, File Server and shared folders, Printers/Scanners, SAS Application) and Agency Websites (Internal Admin Websites, Mail Room Printer Queue, Content Manager (CM) Reference Website, SEAA Loan Lookup, CFI Loan Lookup Website, Tableau Website).